API surge incident
Incident Report for Geocode Earth
Resolved
We have resolved the immediate source of unexpectedly high request volume to our service.

While the volume was extreme, our goal is to ensure no possible source of disruption can affect our service so we will follow up with long term mitigations and an incident report.
Posted Jul 29, 2024 - 19:10 UTC
Update
We have set up mitigations to handle extremely high query volume, and the service is operating normally. We will continue to monitor.
Posted Jul 29, 2024 - 16:54 UTC
Monitoring
Our APIs are experiencing performance degradation due to a large volume of inbound queries. This caused intermittent delays and failures for some users attempting to access our services. The issue has been identified and a fix has been implemented to restore normal operations.
Posted Jul 29, 2024 - 16:00 UTC
This incident affected: Geocode Earth API endpoints (Autocomplete API, Search API, Reverse API) and Geocode Earth Dashboard.