Maintenance is completed and everything looks good.
This update will help us process usage data significantly faster and more efficiently.
Posted Feb 01, 2025 - 02:10 UTC
Verifying
Maintenance is completed and we are monitoring impact.
Posted Feb 01, 2025 - 01:19 UTC
Update
Maintenance is still ongoing but is nearing completion. New estimate 02:15 UTC.
Posted Feb 01, 2025 - 00:50 UTC
Update
Maintenance is proceeding well, but taking longer than scheduled. New estimate is completion in 1.5 hours total, or 00:30 UTC
Posted Feb 01, 2025 - 00:01 UTC
In progress
We are performing a database update on our dashboard. Queries to our geocoding APIs will not be affected, but you will temporarily be unable to view usage, update accounts, etc.
Maintenance is expected to take under an hour.
Posted Jan 31, 2025 - 23:13 UTC
Scheduled
We are performing a database update on our dashboard. Queries to our geocoding APIs will not be affected, but you will temporarily be unable to view usage, update accounts, etc.
Maintenance is expected to take under an hour.
Posted Jan 31, 2025 - 23:12 UTC
This scheduled maintenance affected: Geocode Earth Dashboard.